Wenyan

来自Everything Wiki
跳到导航 跳到搜索
0.00
(0票)

Template:Distinguish Template:Refimprove Template:Infobox programming language

wenyan,亦稱wenyan-lang文言,是以文言文為基礎的一門Template:Citation needed。編譯器主要以JavaScript實作,支援將原始碼編譯為JavaScriptPythonRuby程式碼。[1][2]

不同於大部分中文程式語言,wenyan不只是以中文取代其他程式語言的關鍵字。它定義了自己的語法,使之讀起來接近古文。wenyan常用的符號只有中文字和引號,亦不須分行,以符合古人的書寫習慣。[3][4][5]

Hello, world!

吾有一言。曰「「問天地好在。」」
書之。

[6]

語法

僅需要使用中文字和引號,其餘的標點符號、斷行、縮排都不是必要的。原則上以繁體中文書寫。[7]

定義變數

吾有一數。曰一。名之曰「甲」。

將甲定義為1。

定義函數

吾有一術 名之曰「相加」
欲行是術 必先得二數 曰「甲」 曰「乙」
乃行是術曰
  加「甲」於「乙」
  乃得矣
是謂「相加」之術也

定義一個函數稱為「相加」。接受兩個參數,甲和乙。把甲和乙相加,然後傳回。

呼叫函數

施「相加」於十 於十一

將10和11作為參數傳入。

流程控制

選擇結構

若 一不大於二 者
  吾有一言 曰「「一不大於二。」」
  書之
若非
  吾有一言 曰「「一大於二。」」
  書之
也

如果1 ≤ 2,印出「一不大於二。」否則印出「一大於二。」

重複結構

為是百遍
  吾有一數 曰零
  書之
云云

印出100個0。

吾有一數 曰零 名之曰「甲」
恆為是 若 「甲」不小於一百者 乃止也
  加「甲」以一
  昔之「甲」者 今其是矣
  夫「甲」書之
云云

印出1到100。

使用模組

吾嘗觀「「易經」」之書。方悟「運」「占」之義。

參考資料

Template:Reflist


您未被允许发表评论。